
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

LUCRAREA NR. 12 

 

PROGRAMAREA 
OPERAȚIILOR DE STRUNJIRE  

ÎN MEDIUL CAPSTURN 

 

 
 
Lucrarea prezintă mediul integrat CAD-CAM CAPSturn folosit pentru 
proiectarea unei piese, generarea automată a programului de 
prelucrare și simularea operațiilor de strunjire.   



 PROGRAMAREA MAȘINILOR-UNELTE CU COMANDĂ NUMERICĂ 
 

 

CE TREBUIE SĂ CUNOAȘTEM ? 

 

 

Ce este mediul CAPSturn? 

 

Mediul CAPSturn, este un sistem CAD-CAM, care oferă posibilitatea 
desenării unei piese, generării automate a programului de prelucrare 
(codul G) și simulării grafice a programului generat. Codul poate fi generat 
automat pentru diferite tipuri de controlere (FANUC, SIEMENS, etc.) 
folosite de strungurile cu comandă numerică. 

Accesarea mediului CAPSturn se face cu un dublu click pe iconița  de pe desktop. Se 
va deschide interfața prezentată în figura 12.1.  
 

 
Figura 12.1 Fereastra principală a mediului CAPSturn 
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Cum se ajunge la vizualizarea prelucrării unei piese și a 
codului generat automat? 

 

Pentru a putea vizualiza operațiile de prelucrare a unei piese și codul 
generat automat, este necesară parcurgerea secvenței de pași prezentați 
mai jos: 
 
Pasul 1 - Crearea unui nou program; 
Pasul 2 – Stabilirea setărilor inițiale; 
Pasul 3 – Desenarea piesei ce urmează a fi prelucrată; 
Pasul 4 – Definirea geometriei materialului din care se va prelucra piesa; 
Pasul 5 – Definirea operațiilor de prelucrare; 
Pasul 6 – Selectarea tipului de controler; 
Pasul 7 – Simularea grafică a operațiilor de prelucrare; 
Pasul 8 – Generarea codului G. 

 

Pentru a deprinde mai ușor modul de lucru cu mediul CAPSturn, se 
propune realizarea unei piese a cărei vedere în secțiune longitudinală 
este prezentată în figura 12.2. 
 

 

 
 

Figura 12.2 Vedere în secțiune longitudinală a piesei de prelucrat 

 231 
 



 PROGRAMAREA MAȘINILOR-UNELTE CU COMANDĂ NUMERICĂ 
 
Piesa se va prelucra dintr-un material brut de formă cilindrică a cărui secțiune longitudinală 
este prezentată în figura 12.3. 

 

 
 

Figura 12.3 Piesa brută din care se va prelucra piesa finită 

Desenarea acestei piese, definirea operațiilor de prelucrare, simularea și analiza codului 
generat vor presupune o serie de acțiuni care au ca scop familiarizarea cu cât mai multe 
dintre facilitățile mediului CAPSturn. Piesa rezultată după parcurgerea pașilor anterior 
menționați, detaliați în continuare, este prezentată în figura 12.4. 

 

 
Figura 12.4 Piesa rezultată în urma prelucrării prin strunjire 
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Cum se creează un nou program? 

 

La deschiderea mediului CAPSturn (vezi figura 12.1), se va alege opțiunea 
File ->New sau se va selecta iconița , aflată sub bara meniului principal. 

 

 

Cum se stabilesc setările inițiale? 

 

După acțiunea de creare a unui nou program se va deschide fereastra 
Worksetup, în care se pot face următoarele setări, grupate în trei tab-uri (vezi 
figurile 12.5a, 12.5b și 12.5c): 
- setări generale (tab-ul Setup data1) referitoare la:  

- unitatea de măsură folosită (mm sau inci); 
- tipul materialului brut; 
- modul de prindere a piesei (extern sau intern); 
- timpul de încărcare și descărcare pe/de pe mașină; 
- viteza maximă a arborelui; 
- poziția universalului (mandrinei cu bacuri (fălci)) pe Z; 
- distanța de siguranță pe axa Z (eng. clearance); 
- distanța de siguranță pe diametrul interior; 
- distanța de siguranță pe diametrul exterior. 

- setări referitoare la scule și fălcile universalului (tab-ul Setup data2) pentru: 
- stabilirea poziției în care se schimbă scula; 
- modul de programare (în rază sau în diametru); 
- poziția implicită a revolverului; 
- orientarea sculei; 
- dimensiunile fălcilor universalului. 

  - documentarea programului (tab-ul Documentation) presupune adăugarea 
  unor informații referitoare la: 

- numărul piesei; 
- numele piesei; 
- numărul setării; 
- tipul dispozitivelor de fixare a piesei în universal; 
- numele programatorului; 
- alte observații. 

Completați câmpurile din cele 3 ferestre ca în imaginile de mai jos. 
 
Se va considera că piesa brută este turnată din aliaj de fier cu duritate 
medie. 
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(a) (b) 

 
(c) 

Figura 12.5 Setări inițiale: (a)setări generale, (b)setări referitoare la scule și universal, (c)documentarea 
programului. 

 

 

Cum se desenează piesa ce urmează a fi prelucrată? 

 

Mediul CAPSturn permite desenarea unui obiect având orice geometrie care 
poate fi prelucrată pe un strung.  
Crearea lui în plan se poate face, fie folosind forme geometrice predefinite, 
configurabile (de exemplu: canal, șanfren), fie  segmente (linie dreaptă, arc 
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de cerc) care sunt apoi unite pentru a defini conturul piesei. Este necesar să 
se deseneze doar jumătate din piesă (în plan longitudinal). Piesa în întregime 
se va genera în mod automat. 
Opțiunile de desenare sunt disponibile alegând din meniul principal (vezi 
figura 12.6) opțiunea Draw. 
Se pot defini astfel: 

- contururi (formate din mai multe linii); 
- linii, arce de cerc sau cercuri, folosind diferite metode; 
- raze și teșituri; 
- forme (canale cu diferite geometrii). 

Pentru editare sunt de asemenea folosite opțiunile meniului Edit (vezi figura 
12.7). 

 

 

Pentru a avea acces la meniurile Draw și Edit, este necesar ca tab-ul 
Geometry, aflat în colțul din stânga jos al ferestrei principale, să fie selectat. 

 
 

 

 

 
Figura 12.6 Opțiunile meniului Draw Figura 12.7 Opțiunile meniului Edit 

 
Piesa din figura 12.2, va fi desenată segment cu segment. Se va ține cont de faptul că toate 
dimensiunile vor fi exprimate în milimetri și că se va lucra în coordonate absolute.  De 
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menționat că soluția oferită nu este unică, același segment putând fi definit prin mai multe 
metode, chiar dacă rezultatul este același.  

 

Toate coordonatele pe axa X se vor exprima în diametru! 

În continuare sunt prezentați pașii necesari, fiind indicat să se salveze proiectul după fiecare 
pas: 
 
Pasul 1 Selectați Draw -> Line -> Point- point și: 

- în fereastra care se deschide introduceți coordonatele punctului de start: 30,-30, apoi 
apăsați butonul Done; 

- în fereastra următoare introduceți coordonatele punctului de final: 30,-20, apoi 
apăsați butonul Done. 
 

Pasul 2 Selectați iconița  disponibilă deasupra ferestrei de lucru și: 
- în fereastra care se deschide introduceți coordonatele punctului de start: 40,-25, apoi 

apăsați butonul Done; 
- în fereastra următoare introduceți coordonatele punctului de final: 40,-16.5, apoi 

apăsați butonul Done. 
 

 

Cele două segmente desenate sunt mai mari decât ar trebui să fie, dar vor fi 
ajustate după unirea cu arcul de cerc de rază 5 (de pe conturul interior al 
piesei). 

 
Pasul 3 Selectați Draw -> Arc -> Start- center-end și: 

- în fereastra care se deschide introduceți coordonatele punctului de start: 40,-20, apoi 
apăsați butonul Done; 

- în fereastra următoare introduceți coordonatele centrului arcului de cerc: 30,-20, apoi 
apăsați butonul Done; 

- iar în următoarea fereastră introduceți coordonatele punctului de final: 30,-25, apoi 
apăsați butonul Done. 
 

 

Ori de câte ori doriți să vedeți mai în detaliu o anumită zonă de pe desen, 
folosiți opțiunea View -> Zoom all sau opțiunea View -> Zoom. 
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Dacă ați urmat corect pașii 1, 2 și 3, desenul ar trebui să arate precum cel din figura 12.8: 

 
Figura 12.8 Desenul piesei după pasul 3 

Pasul 4 Selectați Edit -> Trim și: 
- la mesajul care apare faceți click pe segmentele marcate în figura 12.9, în ordinea 

indicată, apoi apăsați butonul Done. Ar trebui ca tot desenul să se coloreze în roșu. 

 
Figura 12.9 Operația de decupare 

- la mesajul următor, faceți click, în ordine, doar pe segmentele 1 și 3, în punctele 
marcate în figura 12.9, apoi apăsați butonul Done; 

- desenul ar trebui să arate ca în figura 12.10. 

 
Figura 12.10 Desenul după pasul 4 

 
Pasul 5 Selectați Draw -> Line -> Point- point și: 

- în fereastra care se deschide introduceți coordonatele punctului de start: 40,-16.5, 
apoi apăsați butonul Done; 

- în fereastra următoare introduceți coordonatele punctului de final: 40,0, apoi apăsați 
butonul Done. 

 
Pasul 6 Selectați Draw -> Line -> Point- point și: 

- în fereastra care se deschide introduceți coordonatele punctului de start: 40,0, apoi 
apăsați butonul Done; 
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- în fereastra următoare introduceți coordonatele punctului de final: 54,0, apoi apăsați 
butonul Done. 

Pasul 7 Selectați Draw -> Line -> Point- point și: 
- în fereastra care se deschide introduceți coordonatele punctului de start: 54,0, apoi 

apăsați butonul Done; 
- în fereastra următoare introduceți coordonatele punctului de final: 54,-12, apoi 

apăsați butonul Done. Desenul ar trebui să arate ca cel din figura 12.11. 

 
Figura 12.11 Desenul după pasul 7 

 
Pasul 8 S-a omis desenarea teșiturii. Pentru realizarea acesteia procedați astfel:  

- selectați Draw -> Chamfer; 
- în fereastra care se deschide selectați opțiunea „laturi egale ale teșiturii” și în câmpul 

Distance introduceți valoarea 2; Lăsați nemodificate restul opțiunilor. 
- la mesajul Select the first object faceți click pe segmentul 1 (vezi figura 12.12); 
- la mesajul Select the second object faceți click pe segmentul 2, apoi apăsați butonul 

Done. Desenul ar trebui să arate ca cel din figura 12.13. 
 

 
 

Figura 12.12 Desenarea teșiturii Figura 12.13 Desenul după pasul 8 
 

Pasul 9 Selectați Draw -> Groove și: 
- în fereastra care se deschide introduceți în câmpul Depth valoarea 2, și în câmpul Base 

width valoarea 18, apoi apăsați butonul OK; 
- în fereastra care se deschide introduceți coordonatele punctului de start al canalului: 

54,-12, apoi apăsați butonul Done. 
 
Desenul ar trebui să arate ca cel din figura 12.14. 
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Figura 12.14 Desenarea canalului 

Pasul 10 Selectați Draw -> Multiline  și: 
- în fereastra care se deschide introduceți coordonatele punctului de start: 54,-30, apoi 

apăsați butonul Done; 
- în ferestrele următoare introduceți  pe rând, în pereche, coordonatele: 54,-41   64,-46  

70,-46  80,-55  80,-65, apăsând după fiecare pereche butonul Done, iar după ultima 
pereche apăsați de două ori butonul Done. 

Desenul ar trebui să arate ca cel din figura 12.15. 

 
Figura 12.15 Desenul după pasul 10 

 
Pasul 11 Selectați Draw -> Define part și: 

- la mesajul Select the first object faceți click pe ultimul segment adăugat la pasul 
anterior; 

- la mesajul Create part shape? selectați Yes. 
Dacă ați procedat corect, desenul ar trebui să arate precum cel din figura 12.16. 

 
Figura 12.16 Desenul piesei după pasul 11 
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 În acest moment piesa este definită complet din punct de vedere geometric. 
 

 

Cum se definește materialul din care se va prelucra 
piesa? 

 

Geometria materialului brut trebuie construită și apoi, conturul rezultat 
trebuie configurat ca materie primă. 
Mai jos sunt prezentați pașii necesari definirii materialului brut conform 
desenului din figura 12.3. 
 
Așa cum se va putea observa, materialul brut va ieși pe axa Z cu 2 mm în 
afara punctului de zero piesă. Cei 2 mm vor fi înlăturați prin operația de 
strunjire frontală. De asemenea surplusul de material de pe diametrul 
exterior și cel interior, va fi înlăturat prin operații de strunjire laterală.  

 
Pasul 1 Selectați Draw -> Multiline  și: 

- în fereastra care se deschide introduceți coordonatele punctului de start: 26,-30, apoi 
apăsați butonul Done; 

- în ferestrele următoare introduceți pe rând, în pereche, coordonatele: 26,2   86,2  86,-
90, apăsând după fiecare pereche butonul Done, iar după ultima pereche apăsați de 
două ori butonul Done. 

Desenul ar trebui să arate ca cel din figura 12.17. 

 
Figura 12.17 Desenul materialului brut (conturul alb) după pasul 1 

Pasul 2 Selectați Draw -> Define blank  și: 
- în fereastra care se deschide apăsați butonul Select contour; 
- la mesajul Select the first object, faceți click pe primul segment desenat la definirea 

conturului materialului brut (cel din partea de jos); 
- la mesajul Create blank shape? selectați opțiunea Yes. 
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Desenul ar trebui să arate ca cel din figura 12.18. 

 
Figura 12.18 Desenul materialului brut după pasul 2 

În acest moment materialul brut este complet definit. 

În figura 12.19 este prezentată imaginea completă a materialului brut și a conturului piesei ce 
urmează a fi prelucrată. 

 

 
Figura 12.19 Desenul materialului brut și al piesei de prelucrat 
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Cum se definesc operațiile de prelucrare? 

 

Realizarea piesei din figura 12.2, presupune mai multe operații: 
- strunjire grosieră frontală; 
- strunjire grosieră pe conturul exterior; 
- strunjire grosieră pe conturul interior; 
- strunjire de finisare frontală; 
- strunjire de finisare pe conturul exterior; 
- strunjire de finisare pe conturul interior; 
- strunjire canal; 
- prelucrare filet interior. 

 
Operațiile prezentate mai sus, vor fi descrise pas cu pas în continuare, 
menționându-se la fiecare, după caz, setările necesare. 

 

 

Pentru a avea acces la meniul Machining, este necesar ca tab-ul Machining, 
aflat în partea din stânga jos, a ferestrei principale, să fie selectat.  

 

 

Ori de câte ori nu se precizează explicit modificarea unor câmpuri din 
ferestrele care se vor deschide, aceste câmpuri vor rămâne cu valorile 
implicite. 

 

Pasul 1 Selectați Machining -> Turning -> Plain face și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: External turn -> Shank size 16x16; 
 - Select tool:  PCLNL 1616H09 R0.8; 
 - Select tool material: Coated carbide. 

- selectați butonul OK; 
- la mesajul Select start X on BLANK or PART, selectați punctul 1 ca în figura 12.20; 
- la mesajul Select end X on BLANK or PART, selectați punctul 2 ca în figura 12.20; 
- în fereastra Plain face care se deschide dați un nume operației de strunjire în câmpul 

Operation name și lăsați nemodificați restul parametrilor. Se va lăsa astfel o grosime 
de material de 0,5 mm pentru finisare, iar grosimea stratului înlăturat la o trecere va fi 
de maxim 3 mm. 
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Figura 12.20 Selectarea traiectoriei pentru strunjirea frontală grosieră 

 
- apăsați butonul OK. 

În acest moment operația de strunjire frontală grosieră este complet definită. 
 

Pasul 2 Selectați Machining -> Turning -> Contour turn și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: External turn -> Shank size 20x20; 
 - Select tool:  PCLNL 2020K09 R0.8; 
 - Select tool material: Coated carbide. 

- selectați butonul OK; 
- la mesajul Select start point of machining on the PART, selectați punctul 1 ca în figura 

12.21; 
- la mesajul Select the end  point of machining on the PART, selectați punctul 2 ca în 

figura 12.21; 
- în fereastra Contour turn care se deschide dați un nume operației de strunjire în 

câmpul Operation name și lăsați nemodificați restul parametrilor. Se va lăsa astfel o 
grosime de material de 0,5 mm pentru finisare, iar grosimea stratului înlăturat la o 
trecere va fi de maxim 3 mm; 

- apăsați butonul OK. 
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Figura 12.21 Selectarea traiectoriei pentru strunjirea grosieră pe conturul exterior 

În acest moment operația de strunjire grosieră pe conturul exterior este complet definită. 
 

Pasul 3 Selectați Machining -> Turning -> Contour turn și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: Internal turn -> 06 Diameter boring bars; 
 - Select tool:  S06H STFCL 06 R0.8; 
 - Select tool material: Coated carbide. 

- selectați butonul OK; 
- la mesajul Select start point of machining on the PART, selectați punctul 1 ca în figura 

12.22; 
- la mesajul Select the end  point of machining on the PART, selectați punctul 2 ca în 

figura 12.22; 
- în fereastra Contour turn care se deschide dați un nume operației de strunjire în 

câmpul Operation name și lăsați nemodificați restul parametrilor. Se va lăsa astfel o 
grosime de material de 0,5 mm pentru finisare, iar grosimea stratului înlăturat la o 
trecere va fi de maxim 3 mm. 

- apăsați butonul OK. 

 
Figura 12.22 Selectarea traiectoriei pentru strunjirea grosieră pe conturul interior 
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În acest moment operația de strunjire grosieră pe conturul interior este complet definită. 

 
Pasul 4 Selectați Machining -> Turning -> Finish face și: 

- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: External turn -> Shank size 16x16; 
 - Select tool:  PCLNL 1616H09 R0.4; 
 - Select tool material: Coated carbide. 

- selectați butonul OK; 
- la mesajul Select start point of machining on the PART, selectați punctul 1 ca în figura 

12.23; 
- la mesajul Select the end point of machining on the PART, selectați punctul 2 ca în 

figura 12.23; 
- în fereastra Finish face care se deschide dați un nume operației de strunjire în câmpul 

Operation name și puneți 0 atât pentru X cât și pentru Z în câmpurile Finish allowance. 
Lăsați nemodificați restul parametrilor.  

 
Figura 12.23 Selectarea traiectoriei pentru strunjirea frontală de finisare 

 
- apăsați butonul OK. 

În acest moment operația de strunjire frontală de finisare este complet definită. 
 

Pasul 5 Selectați Machining -> Turning -> Finish turn și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: External turn -> Shank size 20x20; 
 - Select tool:  PDJNL 2020K11 R0.4; 
 - Select tool material: Coated carbide. 

- selectați butonul OK; 
- la mesajul Select start point of machining on the PART, selectați punctul 1 ca în figura 

12.24; 
- la mesajul Select the end point of machining on the PART, selectați punctul 2 ca în 

figura 12.24; 
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- în fereastra Finish turn care se deschide dați un nume operației de strunjire în câmpul 
Operation name și puneți 0 atât pentru X cât și pentru Z în câmpurile Finish allowance. 
Lăsați nemodificați restul parametrilor.  

- apăsați butonul OK. 
 

 
Figura 12.24 Selectarea traiectoriei pentru strunjirea de finisare pe conturul exterior 

În acest moment operația de strunjire de finisare pe conturul exterior este complet definită. 
 
Pasul 6 Selectați Machining -> Turning -> Finish turn și: 

- în fereastra care se deschide selectați butonul New tool aflat în partea stângă, jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: Internal turn -> 06 Diameter boring bars; 
 - Select tool:  S06H STFCL 06 R0.2; 
 - Select tool material: Coated carbide. 

- selectați butonul OK; 
- la mesajul Select start point of machining on the PART, selectați punctul 1 ca în figura 

12.25; 
- la mesajul Select the end  point of machining on the PART, selectați punctul 2 ca în 

figura 12.25; 
- în fereastra Finish turn care se deschide dați un nume operației de strunjire, în câmpul 

Operation name și puneți 0 atât pentru X cât și pentru Z în câmpurile Finish allowance. 
Lăsați nemodificați restul parametrilor. 

- apăsați butonul OK. 
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Figura 12.25 Selectarea traiectoriei pentru strunjirea de finisare pe conturul interior 

În acest moment operația de strunjire de finisare pe conturul interior este complet definită. 
 
Pasul 7 Selectați Machining -> Turning -> Groove -> Radial și: 

- în fereastra care se deschide selectați butonul New tool aflat în partea stângă, jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: External groove -> Grooving – 12x12; 
 - Select tool:  12x12, 2.00W, 0.2R, 08Depth; 
 - Select tool material: HSS; 
 - Reference edge: Right. 

- selectați butonul OK; 
- la mesajul Select the groove, selectați un punct pe conturul colorat în albastru; 
- în fereastra External groove care se deschide dați un nume operației de canelare în 

câmpul Operation name  și lăsați nemodificați restul parametrilor; 
- apăsați butonul OK. 

În acest moment operația de canelare exterioară este complet definită. 
 

Pasul 8 Selectați Machining -> Turning -> Thread și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: Internal thread -> Internal thread; 
 - Select tool:  Thread dia. 16.0, 55 deg., Depth 2; 
 - Select tool material: Coated carbide. 

- selectați butonul OK; 
- la mesajul Select a line for threading, selectați ca în figura 12.26; 
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Figura 12.26 Selectarea traiectoriei pentru strunjirea filetului interior 

 
- în fereastra Threading care se deschide dați un nume operației de filetare în câmpul 

Operation name  și completați restul parametrilor, ca în figura 11.27. 
 

 
Figura 12.27 Configurarea parametrilor pentru operația de filetare 

 
- apăsați butonul OK. 

În acest moment toate operațiile de prelucrare au fost complet definite. 
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Cum se selectează tipul de controler pentru care se va 
genera programul? 

 

Înainte de a putea vizualiza operațiile anterior configurate, este nevoie să se 
aleagă controlerul pentru care se va genera programul. Este cunoscut faptul 
că pentru controlere diferite (chiar și de la aceeași firmă), programul poate 
să fie diferit, chiar dacă rezultatul în urma executării programului este 
același. 
 
Selectați controlerul astfel: 

- alegeți din bara de meniu opțiunea Machine; 
- în fereastra care se deschide selectați Sinumerik-810T; 
- apăsați butonul Select. 

 
În acest moment se va genera programul pentru controlerul Sinumerik-810T, 
produs de firma Siemens. 

 

 

Cum se simulează operațiile de prelucrare? 

 

Pentru simularea grafică a operațiilor de prelucrare este necesar, în primul 
rând, să fie selectat tab-ul Toolpath, aflat în partea stângă, jos, a ferestrei 
principale. 
 
Vor deveni disponibile, în partea superioară a ferestrei principale, o serie de 
butoane (vezi figura 12.28) folosite pentru: 

- modul de vizualizare a piesei; 
- selectarea operației care se dorește a fi simulată; 
- controlul simulării. 

 
În plus, pe durata simulării, o serie de informații referitoare la poziția sculei, 
operația curentă, scula folosită, etc, pot fi vizualizate în fereastra din dreapta 
ferestrei de simulare (vezi figura 12.28). 

 

 

Dacă este necesară modificarea parametrilor unei anumite operații, aceasta 
se poate face selectând tab-ul Machining (din partea stângă jos a ferestrei 
principale) și apoi alegând din fereastra Operation (aflată în partea dreaptă 
a ferestrei de simulare) operația care se dorește a fi modificată sau ștearsă. 
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Figura 12.28 Instantaneu din timpul simulării 

 

 

Cum se generează și vizualizează codul programului? 

 

Pentru a putea vizualiza programul, se accesează opțiunea Ncprogram  din 
bara meniului principal. 
În fereastra care se deschide se pot face câteva configurări referitoare la 
modul de numerotare a blocurilor programului principal și ale 
subprogramelor (dacă este cazul). 
Se apasă apoi butonul OK, care va genera programul cu setările anterior 
făcute. 
Pentru vizualizarea/editarea programului, se apasă butonul Edit din fereastra 
care s-a deschis. 

Exemplul anterior prezentat, a avut ca scop principal familiarizarea cu principalele opțiuni ale 
mediului CAPSturn. În continuare se propune o aplicație care să fixeze cunoștințele anterior 
dobândite și să ofere posibilitatea de a utiliza și alte facilități ale mediului CAPSturn. 
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APLICAȚIE 

 

 
Generarea automată a codului G pentru 
prelucrarea prin strunjire pe o mașină cu 
comandă numerică. 

 

 

Se consideră desenul din figura 12.29. 
Se pornește de la un material brut turnat, de formă cilindrică 
cu lungimea de 120 mm și diametrul de 56 mm. Punctul zero 
piesă este ales pe axa longitudinală a piesei, la capătul liber al 
acesteia. Se lucrează în sistem metric și se folosesc 
coordonate absolute. Toate dimensiunile pe axa X vor fi 
exprimate în diametre. 

 
Figura 12.29 Piesa de prelucrat 
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Problema 1 Să se deseneze piesa, conform schiței din figura 12.29. 
Problema 2 Să se configureze operațiile de prelucrare necesare, 
respectând specificațiile de mai jos, apoi să se simuleze și analizeze 
codul generat: 
 
Cerința 1:  Să se realizeze operația de strunjire frontală grosieră. 
Se fac următoarele precizări: 

- Se va alege un cuțit corespunzător; 
- Se va prevedea o grosime de 0,2 mm pentru operația de 

finisare; 
- Operația se va realiza cu viteză constantă; 
- Grosimea maximă a stratului înlăturat la o trecere va fi de 1 

mm. 
 
Cerința 2: Să se realizeze operația de strunjire laterală grosieră. 
Se fac următoarele precizări: 

- Se va alege un cuțit corespunzător; 
- Se va prevedea o grosime de 1 mm pentru operația de finisare; 
- Operația se va realiza cu viteză constantă; 
- Grosimea maximă a stratului înlăturat la o trecere va fi de 2 

mm. 
 

Cerința 3: Să se realizeze operația de strunjire frontală de finisare. 
Se fac următoarele precizări: 

- Se va alege un cuțit corespunzător; 
- Prelucrarea se va face fără a lăsa material în plus; 
- Operația se va realiza cu viteză variabilă. 

 
Cerința 4: Să se realizeze operația de strunjire laterală de finisare. 
Se fac următoarele precizări: 

- Se va alege un cuțit corespunzător; 
- Prelucrarea se va face fără a lăsa material în plus; 
- Operația se va realiza cu viteză constantă. 

 
Cerința 5: Să se realizeze operația de canelare.   
Se fac următoarele precizări: 

- Se va alege un cuțit corespunzător; 
- Se va realiza numai strunjire grosieră, fără să se lase material 

pentru finisare; 
- Se va selecta, la alegere, o metodă de tăiere; 
- Canalul va fi strunjit de la stânga la dreapta. 

 
Cerința 6: Să se realizeze operația de filetare.   
Se fac următoarele precizări: 

- Se va alege un cuțit corespunzător; 
- Se vor prevedea 5 treceri active și 2 pasive pentru realizarea 
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filetului; 
- Filetul va avea un singur început; 
- Filetul nu va mai necesita o operație de finisare. 

 
Cerința 7: Să se realizeze operația de găurire preliminară.  
Se fac următoarele precizări: 

- Se va alege un burghiu corespunzător; 
- Revenirea se va face la Z=100. 

 
Cerința 8: Să se realizeze operația de găurire înfundată.  
Se fac următoarele precizări: 

- Se va alege un burghiu corespunzător; 
- Se va prevedea o întârziere de o secundă la fiecare revenire a 

burghiului din piesă; 
- Adâncimea la prima intrare în piesă va fi de 3 mm; 
- Revenirea se va face la Z=100. 

 
Cerința 9: Să se realizeze operația de debitare.  
Se fac următoarele precizări: 

- Se va alege un cuțit corespunzător; 
- Se va prevedea o teșitură de 5 mm. 

Dacă s-au respectat toate cerințele, piesa rezultată în urma prelucrării ar trebui să arate 
precum cea din figura 12.30. 

 
Figura 12.30 Rezultatul prelucrării piesei din figura 12.29 
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Nr. Enunț Răspuns 
A F 

1. În general operația de lărgire a unei găuri nu se 
poate realiza pe un strung.   

2. În cazul operației de filetare avansul se 
controlează automat în funcție de viteza setată.   

3. 
Strunjirea frontală pe interior se realizează de 
obicei folosind cuțite care au dispozitivul port-
sculă de formă paralelipipedică. 

  

4. În cazul strunjirii longitudinale adâncimea de 
așchiere se referă la deplasări pe axa X.   

5. Diametrul unei piese se modifică în urma operației 
de strunjire frontală.   

6. Pe un strung se pot realiza doar canale a căror 
flancuri sunt înclinate sub același unghi.   

7. 
Operația de găurire preliminară are rolul de a 
asigura o poziționare corectă a burghiului pentru 
găurirea efectivă. 

  

8. 
Ciclul de găurire cu revenire la punct fix este 
folosit atunci când se dorește fărâmițarea 
șpanului. 

  

9. Ciclul de găurire cu revenire la punct variabil este 
folosit atunci când se dorește eliminarea șpanului.   

10. Strunjirea de conturare se poate realiza atât pe 
conturul exterior cât și pe cel interior al unei piese.   

 

 

 

 

 

 

 

 

 
 

 

Problema Puncte Total 
Exemplul 1 1 x 4 4 

Aplicație Problema 1 1 x 2,4 2,4 
Problema 2 9 x 0,4 3,6 

Test 1 1 
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