
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

LUCRAREA NR. 11 

 

PROGRAMAREA 
OPERAȚIILOR DE FREZARE  

ÎN MEDIUL CAPSMILL 

 

 
 
Lucrarea prezintă mediul integrat CAD-CAM CAPSmill folosit pentru 
proiectarea unei piese, generarea automată a programului de 
prelucrare și simularea operațiilor de frezare.   
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CE TREBUIE SĂ CUNOAȘTEM ? 

 

 

Ce este mediul CAPSmill? 

 

Mediul CAPSmill, este un sistem CAD-CAM, care oferă posibilitatea 
desenării unei piese, generării automate a programului de prelucrare 
(codul G) și simulării grafice a programului generat. Codul poate fi generat 
automat pentru diferite tipuri de controlere (FANUC, SIEMENS, etc.) 
folosite de mașinile de frezat, cu comandă numerică. 

Accesarea mediului CAPSmill se face cu un dublu click pe iconița  de pe desktop. Se 
va deschide interfața prezentată în figura 11.1.  
 

 
Figura 11.1 Fereastra principală a mediului CAPSmill 
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Cum se ajunge la vizualizarea prelucrării unei piese și a 
codului generat automat? 

 

Pentru a putea vizualiza operațiile de prelucrare a unei piese și codul generat 
automat, este necesară parcurgerea următoarei secvențe de pași: 
 
Pasul 1 - Crearea unui nou program; 
Pasul 2 – Stabilirea setărilor inițiale; 
Pasul 3 – Desenarea piesei ce urmează a fi prelucrată; 
Pasul 4 – Definirea geometriei materialului din care se va prelucra piesa; 
Pasul 5 – Definirea operațiilor de prelucrare; 
Pasul 6 – Selectarea tipului de controler; 
Pasul 7 – Simularea grafică a operațiilor de prelucrare; 
Pasul 8 – Generarea, vizualizarea și editarea codului G. 

 

 
Pentru a deprinde mai ușor modul de lucru cu mediul CAPSmill, se 
propune realizarea unei piese a cărei vedere de deasupra este 
prezentată în figura 11.2 

 
Figura 11.2 Vedere de deasupra a piesei de prelucrat 
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Desenarea acestei piese, definirea operațiilor de prelucrare, simularea și analiza codului 
generat, vor presupune o serie de acțiuni care au ca scop familiarizarea cu cât mai multe 
dintre facilitățile mediului CAPSmill. Piesa rezultată după parcurgerea pașilor anterior 
menționați, detaliați în continuare, este prezentată în figura 11.3. 

 

 
Figura 11.3 Piesa rezultată în urma prelucrării prin frezare, conform schiței din figura 11.2 

 

 

Informațiile referitoare la dimensiunile materialului brut, grosimea piesei 
finite, adâncimea găurilor, diametrul șanfrenului găurilor teșite, adâncimea 
gravurii, precum și a buzunarului hexagonal, vor fi furnizate pe parcurs. 

 

 

Cum se creează un nou program? 

 

La deschiderea mediului CAPSmill (vezi figura 11.1), din fereastra Start up se 
va selecta opțiunea Create a new part, pentru crearea unei noi piese (un nou 
program). 
În cazul în care fereastra Start up este dezactivată la pornirea mediului 
CAPSmill, se va alege opțiunea File ->New sau se va selecta iconița , 
aflată sub bara meniului principal. 
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Cum se stabilesc setările inițiale? 

 

După acțiunea de creare a unui nou program se va deschide fereastra 
Worksetup, în care se pot face următoarele setări, grupate în trei tab-uri (vezi 
figurile 11.4a, 11.4b și 11.4c): 
- setări generale (tab-ul Setup data) referitoare la:  

- unitatea de măsură folosită (mm sau inci); 
- tipul materialului brut; 
- timpul de încărcare și descărcare pe/de pe mașină; 
- distanța de siguranță pe axa Z (eng. clearance); 
- poziția în spațiul de lucru unde are loc schimbarea sculelor. 

- selectarea tipului mesei de lucru (tab-ul Table setup) permite alegerea  
  mesei de lucru, în funcție de: forma piesei, existența axelor suplimentare,  
  orientarea arborelui, etc; 
- documentarea programului (tab-ul Documentation) presupune adăugarea 
  unor informații referitoare la: 

- numărul piesei; 
- numele piesei; 
- numărul setării; 
- tipul dispozitivelor de fixare a piesei pe masă; 
- numele programatorului; 
- alte observații. 

Completați câmpurile din cele 3 ferestre ca în imaginile de mai jos. 
 
Se va considera că piesa brută este turnată din aliaj de fier cu duritate 
medie. 

 

  
(a) (b) 

 201 
 



 PROGRAMAREA MAȘINILOR-UNELTE CU COMANDĂ NUMERICĂ 
 

 
(c) 

Figura 11.4 Fereastra setărilor inițiale: (a)setări generale, (b)selectarea mesei de lucru, 
(c)documentarea programului. 

 

 

Cum se desenează piesa ce urmează a fi prelucrată? 

 

Mediul CAPSmill permite desenarea unui obiect având orice geometrie.  
Crearea lui în plan se poate face, fie folosind forme geometrice predefinite, 
configurabile (de exemplu: cerc, paralelipiped, etc), fie  segmente (linie 
dreaptă, arc de cerc) care sunt apoi unite pentru a defini conturul piesei, fie 
o combinație de forme geometrice și segmente. 
Opțiunile de desenare sunt disponibile alegând opțiunea Draw  din meniul 
principal (vezi figura 11.5). 
Se pot defini astfel: 

- contururi (formate din mai multe linii); 
- linii, arce de cerc sau cercuri, folosind diferite metode; 
- raze și teșituri; 
- forme: poligoane, canale cu diferite geometrii, paralelipipede, etc; 
- puncte amplasate pe o anumită traiectorie; 
- puncte aranjate după un anumit șablon; 
- etc. 

Pentru editare sunt de asemenea folosite opțiunile meniului Edit (vezi figura 
11.6). 

 

 

Pentru a avea acces la meniurile Draw și Edit, este necesar ca tab-ul 
Geometry, aflat în colțul din stânga jos al ferestrei principale, să fie selectat. 
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Figura 11.5 Opțiunile meniului Draw Figura 11.6 Opțiunile meniului Edit 

 
Piesa din figura 11.2, va fi desenată segment cu segment. Se va ține cont de faptul că toate 
dimensiunile vor fi exprimate în milimetri și că se va lucra în coordonate absolute.  De 
menționat că soluția oferită nu este unică, același segment putând fi definit prin mai multe 
metode. Pe cât posibil, s-a încercat să se prezinte metode diferite tocmai cu scopul de a 
scoate în evidență caracterul versatil al mediului CAPSmill, în ceea ce privește opțiunile de 
desenare. În continuare sunt prezentați pașii necesari, fiind indicat să se salveze desenul creat, 
după fiecare pas: 
 
Pasul 1 Selectați Draw -> Line -> Point- point și: 

- în fereastra care se deschide introduceți coordonatele punctului de start: 35,50, apoi 
apăsați butonul Done; 

- în fereastra următoare introduceți coordonatele punctului de final: 48,12, apoi apăsați 
butonul Done. 

Pasul 2 Selectați iconița  disponibilă deasupra ferestrei de lucru și: 
- în fereastra care se deschide introduceți coordonatele punctului de start: 65,50, apoi 

apăsați butonul Done; 
- în fereastra următoare introduceți coordonatele punctului de final: 52,12, apoi apăsați 

butonul Done. 
 
Pasul 3 Selectați Draw -> Arc -> Start-center-end și: 
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- în fereastra care se deschide introduceți coordonatele punctului de start: 48,12, 
apoi apăsați butonul Done; 

- în fereastra următoare introduceți coordonatele centrului arcului de cerc: 50,12, 
apoi apăsați butonul Done; 

- iar în următoarea fereastră introduceți coordonatele punctului de final: 52,12, 
apoi apăsați butonul Done. 

 
Dacă ați urmat corect pașii 1, 2 și 3, desenul ar trebui să arate precum cel din figura 11.7: 

 
Figura 11.7 Desenul piesei după pasul 3 

 

Pasul 4 Selectați Draw -> Circle -> Center-radius și: 
- în fereastra care se deschide introduceți coordonatele centrului cercului: 35,65, apoi 

apăsați butonul Done; 
- în fereastra următoare introduceți raza cercului: 15, apoi apăsați butonul Done. 

 
Pasul 5 Selectați Draw -> Circle -> Center-diameter și: 

- în fereastra care se deschide introduceți coordonatele centrului cercului: 65,65, apoi 
apăsați butonul Done; 

- în fereastra următoare introduceți diametrul cercului: 30, apoi apăsați butonul Done. 
 
Pasul 6 Selectați Draw -> Circle -> Point-point-radius și: 

- în fereastra care se deschide introduceți coordonatele primului punct: 35,80, apoi 
apăsați butonul Done; 

- în fereastra care se deschide introduceți coordonatele celui de-al doilea punct: 65,80, 
apoi apăsați butonul Done; 

- în fereastra următoare introduceți raza cercului: 15, apoi apăsați butonul Done. 
 

Dacă ați urmat corect pașii 4, 5 și 6, desenul ar trebui să arate precum cel din figura 11.8. 

Desenul rezultat este diferit de cel prezentat în figura 11.2, de accea sunt necesare unele 
decupări, astfel încât să fie conform cu cel din figura 11.2. 
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Figura 11.8 Desenul piesei după pasul 6 

 
Pasul 7 Selectați View -> Zoom all pentru a vedea desenul realizat la dimensiunile maxime 
             posibile. 
 
Pasul 8 Selectați Edit -> Trim și: 

- apăsați butonul dreapta al mouse-ului și din meniul care se deschide selectați 
opțiunea Select all. Liniile desenului ar trebui să se coloreze în roșu; 

- apăsați butonul dreapta al mouse-ului și din meniul care se deschide selectați 
opțiunea Done; 

- selectați apoi pe rând, fiecare arc de cerc care nu ar trebui să facă parte din desenul 
final. Imediat ce l-ați selectat ar trebui să dispară. 

- după ce ați șters toate arcele în plus, apăsați butonul Done. 
 

Dacă ați procedat corect, desenul ar trebui să arate precum cel din figura 11.9. 

 
Figura 11.9 Desenul piesei după pasul 8 

 
Pasul 9 Selectați Draw -> Define contour -> Auto contour și: 
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- faceți click oriunde pe contur, apoi la mesajul Do you want to save it as a contour 
alegeți opțiunea Yes. Conturul ar trebui să se coloreze în albastru. 

 
Pasul 10 Selectați Draw -> Define contour-> Offset contour și: 

- faceți click pe circumferința arcului de cerc din dreapta (conturul piesei ar trebui să se 
coloreze în roșu); 

- la mesajul Specify the side to offset the contour, dați click undeva în afara conturului; 
- la mesajul Specify the offset distance introduceți valoarea 3, apoi apăsați butonul Done. 

 
Valoarea 3 semnifică faptul că piesa brută are 3 mm în plus pe tot conturul piesei, 
ceea ce înseamnă că acest surplus va trebui înlăturat prin operații de frezare laterală. 
Dacă ați procedat corect desenul ar trebui să arate precum cel din figura 11.10. 

 

 
Figura 11.10 Desenul piesei după pasul 10 

 
Pasul 11 Selectați Draw -> Shapes -> Polygon și: 

- completați câmpurile ca mai jos, apoi selectați butonul Color și alegeți o culoare 
pentru buzunarul hexagonal: 
 - Diameter of enclosing circle: 20; 
 - Number of sides: 6; 
 - Corner radius: 2; 
 - Rotation angle: 0. 

- la mesajul Enter the center for polygon introduceți coordonatele centrului poligonului: 
50,45, apoi apăsați butonul Done. 
 
Dacă ați procedat corect desenul ar trebui să arate precum cel din figura 11.11. 
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Figura 11.11 Desenul piesei după pasul 11 

 
Pasul 12 Selectați Draw -> Text și:  

- completați câmpurile ca mai jos, apoi selectați butonul Color și alegeți o culoare 
pentru text, apoi apăsați butonul OK: 

 - Enter text: CNMU; 
 - Store as machinable object: bifați; 
 - Font: Arial; 
 - Style: Bold; 
 - Rotation angle: 0; 
 - Size: 22; 
 - Distance between letters: 2. 
- la mesajul Specify a point introduceți coordonatele colțului din stânga jos al blocului 

text: 32,60, apoi apăsați butonul Done. 
 
Dacă ați procedat corect desenul ar trebui să arate precum cel din figura 11.12. 

 
Figura 11.12 Desenul piesei după pasul 12 
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Pasul 13 Selectați Draw -> Point pattern -> Points on arc-equally spaced  și: 

- completați câmpurile ca mai jos, apoi selectați butonul Color și alegeți o culoare 
pentru găuri, apoi apăsați butonul OK: 

 - Arc radius: 10; 
 - Angular pitch: 30; 
 - Angle of first hole: 0; 
 - Angle of last hole: 180. 
- la mesajul Enter the center point for this pattern introduceți valorile: 50,80, apoi 

apăsați butonul Done. 
Dacă ați procedat corect desenul ar trebui să arate precum cel din figura 11.13. 

 
Figura 11.13 Desenul piesei după pasul 13 

 
 În acest moment piesa este definită complet din punct de vedere geometric. 
 

 

Cum se definește geometria materialul din care se va 
prelucra piesa? 

 

Selectați Draw -> Define blank și: 
- în fereastra care se deschide selectați butonul Select contour aflat în 

partea stângă, jos; 
- selectați conturul exterior; 
- se va redeschide fereastra Define blank  în care, în câmpul Blank 

thickness scrieți 25, iar în câmpul Z coordinate at the bottom scrieți 0; 
- selectați butonul OK. 

 
În acest moment s-au definit dimensiunile materialului brut. Acesta are 
forma piesei finale dar cu 3 mm în plus pe contur și are o grosime de 25 
mm. Punctul zero-piesă este ales pe axa Z la baza piesei.  
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Cum se definesc operațiile de prelucrare? 

 

Realizarea piesei din figura 11.2, presupune mai multe operații: 
- frezarea grosieră frontală; 
- frezarea de finisare frontală; 
- frezarea grosieră pe contur; 
- frezarea de finisare pe contur; 
- realizarea buzunarului; 
- gravarea textului; 
- găurirea preliminară a celor 7 găuri; 
- găurirea înfundată a celor 7 găuri; 
- șanfrenarea găurilor 1, 3, 5 și 7. 

 
Operațiile prezentate mai sus, vor fi descrise pas cu pas, în continuare, 
menționându-se la fiecare, după caz, setările necesare. 
 

 

 

Pentru a avea acces la meniul Machining, este necesar ca tab-ul Machining, 
aflat în partea din stânga jos a ferestrei principale, să fie selectat. 

 

Pasul 1 Selectați Machining -> Milling -> Face mill și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- faceți selecțiile ca mai jos: 

 - Tool library: General (mm); 
 - Select tool type: Face mill -> Face mill – 45 degree; 
 - Select tool:  50.00 mm dia. Face mill; 
 - Select tool material: Carbide. 

- selectați butonul OK; 
- la mesajul Select a contour, selectați conturul exterior, iar în fereastra care se va 

deschide alegeți Contour(), apoi apăsați butonul Done; 
- în fereastra care se deschide completați câmpurile ca în figura 11.14; 
- vizualizați conținutul celorlalte tab-uri, și setați la 3, valoarea maximă a grosimii 

stratului care se înlătură la o trecere; 
- apăsați butonul OK; 
- la mesajul Select a circle to specify the machining start point faceți click pe conturul 

cercului din dreapta sus. 
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Figura 11.14 Stabilirea parametrilor pentru frezarea frontală grosieră și de finisare 

 
În acest moment operațiile de frezare frontală grosieră și de finisare sunt complet definite. 

 
 

Pasul 2 Selectați Machining-> Milling -> Side mill și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- completați câmpurile ca mai jos: 

- Tool library: General (mm); 
 - Select tool type: End mill -> End mill finish-4 flute; 
 - Select tool:  2.00 mm dia. End mill finish-4 flute; 
 - Select tool material: HSS. 

- selectați butonul OK; 
- la mesajul Select a contour, selectați conturul interior, iar în fereastra care se va 

deschide alegeți Contour(), apoi apăsați butonul Done; 
- la mesajul Specify the machining start point selectați un punct de pe conturul interior 

(cel colorat în galben); 
- la mesajul Mill the whole contour selectați butonul Yes; 
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- la mesajul Select a circle to specify the side for milling selectați cerculețul roșu din 
exterior. Astfel frezarea laterală se va realiza dinspre exterior spre interior. 

- în fereastra care se deschide completați câmpurile ca în figura 11.15: 
 

 
Figura 11.15 Stabilirea parametrilor pentru frezarea laterală grosieră și de finisare 

 

- selectați tab-ul Tool entry / exit și completați câmpurile ca în figura 11.16: 
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Figura 11.16 Stabilirea modului de intrare și ieșire a frezei în/din piesă 

 

- selectați tab-ul Cutting parameters și completați câmpurile ca în figura 11.17; 
- apăsați butonul OK; 
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Figura 11.17 Stabilirea vitezei, avansului și adâncimii maxime de frezare la o trecere 

În acest moment operațiile de frezare laterală grosieră și de finisare sunt complet definite. 
 
Pasul 3 Selectați Machining -> Milling -> Pocket și: 

- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- completați câmpurile ca mai jos: 

- Tool library: General (mm); 
 - Select tool type: End mill -> End mill rough-4 flute; 
 - Select tool:  3.00 mm dia. End mill rough-4 flute; 
 - Select tool material: HSS. 

- selectați butonul OK; 
- la mesajul Select a contour, selectați conturul hexagonal, iar în fereastra care se va 

deschide completați câmpurile ca în figura 11.18;  
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Figura 11.18 Stabilirea parametrilor pentru frezarea buzunarului 

 

- selectați tab-ul Cutting method  și completați câmpurile ca în fereastra 11.19; 
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Figura 11.19 Stabilirea modului de intrare a sculei în piesă și a metodei de frezare 

 

- selectați tab-ul Cutting parameters  și completați câmpurile ca în fereastra 11.20; 
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Figura 11.20 Stabilirea parametrilor de frezare 

 
- apăsați butonul OK; 
- la mesajul Specify the entry/exit point for side finish on the pocket, selectați un punct pe 

hexagon și apoi completați în fereastra care se va deschide, ca în figura 11.21. 
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Figura 11.21 Stabilirea modului de intrare și ieșire a frezei în/din piesă, în cazul operației de finisare 

laterală a buzunarului. 

În acest moment operațiile de frezare grosieră și de finisare a buzunarului sunt complet 
definite. 
 

Pasul 4 Selectați Machining -> Milling -> Engrave și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- completați câmpurile ca mai jos: 

- Tool library: General (mm); 
 - Select tool type: Ballnose end mill-> Ballnose end mill; 
 - Select tool:  2.00 mm dia. ballnose-End mill; 
 - Select tool material: HSS. 

- selectați butonul OK; 
- la mesajul Select the object(Press W to select through a window), apăsați tasta W, apoi 

dați click undeva înafara colțului textului, în stânga sus, apoi fără să mai țineți butonul 
apăsat, mutați cursorul mouse-ului astfel încât să fie încadrat tot textul și apăsați 
butonul stâng al mouse-ului; 

- apăsați butonul Done; 
- în fereastra Engrave care se va deschide completați ca mai jos: 
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 - Work surface: 20; 
 - Material depth: 2; 
 - Return to Z: 100. 
- apăsați butonul OK; 

În acest moment operația de gravare a textului este complet definită. 
 

Pasul 5 Selectați Machining -> Hole -> Center drill și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- completați câmpurile ca mai jos: 

- Tool library: General (mm); 
 - Select tool type: Center drill-> Spotting drill 90 deg.; 
 - Select tool:  3.00 mm dia. Spot drill; 
 - Select tool material: HSS. 

- selectați butonul OK; 
- la mesajul Select the points to be machined, or press C to call a subprogram (Press W to 

select through a window), apăsați tasta W, apoi dați click undeva în stânga sus, în afara 
marcajelor pentru cele 7 găuri, apoi fără să mai țineți butonul apăsat, mutați cursorul 
mouse-ului astfel încât să fie încadrate toate marcajele celor 7 găuri (marcajele ar 
trebui să se coloreze în roșu dacă au fost corect selectate) și apăsați butonul stâng al 
mouse-ului; 

- apăsați butonul Done; 
- la mesajul Do you want to omit any holes? selectați opțiunea No; 
- în fereastra Center drill care se va deschide completați ca mai jos: 

 - Work surface: 20; 
 - Tool tip depth: 2; 
 - Cutting speed:  28; 
 - Feed rate: 0.1; 
 - Return to Z: 100. 

- apăsați butonul OK; 

În acest moment operația de găurire preliminară a celor 7 găuri este complet definită. 
 

Pasul 6 Selectați Machining-> Hole -> Peck drilling și: 
- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- completați câmpurile ca mai jos: 

- Tool library: General (mm); 
 - Select tool type: Drill-> Twist drill; 
 - Select tool:  3.00 mm dia. Twist drill; 
 - Select tool material: Carbide. 

- selectați butonul OK; 
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- la mesajul Select the points to be machined, or press C to call a subprogram (Press W to 
select through a window), apăsați tasta W, apoi dați click undeva în stânga sus, în afara 
marcajelor pentru cele 7 găuri, apoi fără să mai țineți butonul apăsat, mutați cursorul 
mouse-ului astfel încât să fie încadrate toate marcajele celor 7 găuri (marcajele ar 
trebui să se coloreze în roșu dacă au fost corect selectate) și apăsați butonul stâng al 
mouse-ului; 

- apăsați butonul Done; 
- la mesajul Do you want to omit any holes? selectați opțiunea No; 
- în fereastra Peck drill care se va deschide completați ca în figura 11.22: 

 
Figura 11.22 Configurarea parametrilor pentru operația de găurire înfundată cu revenire la punct 

variabil 
- apăsați butonul OK; 

În acest moment operația de găurire înfundată cu revenire la punct variabil (cu fărâmițarea 
șpanului), a celor 7 găuri, este complet definită. 
 
Pasul 7 Selectați Machining-> Hole -> Countersinking și: 

- în fereastra care se deschide selectați butonul New tool aflat în partea stângă jos; 
- completați câmpurile ca mai jos: 
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- Tool library: General (mm); 
 - Select tool type: Countersink-> Countersink; 
 - Select tool:  1.50-6.00 mm Countersink 90 deg.; 
 - Select tool material: Carbide. 

- selectați butonul OK; 
- la mesajul Select the points to be machined, or press C to call a subprogram (Press W to 

select through a window), apăsați tasta W, apoi dați click undeva în stânga sus, în afara 
marcajelor pentru cele 7 găuri, apoi fără să mai țineți butonul apăsat, mutați cursorul 
mouse-ului astfel încât să fie încadrate toate marcajele celor 7 găuri (marcajele ar 
trebui să se coloreze în roșu dacă au fost corect selectate) și apăsați butonul stâng al 
mouse-ului; 

- apăsați butonul Done; 
- la mesajul Do you want to omit any holes? selectați opțiunea Yes; 
- la mesajul Select the holes to be omitted, selectați cu mouse-ul marcajele găurilor 2, 4 

și 6; 
- apăsați butonul Done; 
- în fereastra Countersink care se va deschide completați ca în figura 11.23: 

 
Figura 11.23 Configurarea parametrilor pentru operația de șanfrenare selectivă 
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- apăsați butonul OK;   

În acest moment toate operațiile necesare prelucrării sunt complet definite. 

 

Cum se selectează tipul de controler pentru care se va 
genera programul? 

 

Înainte de a putea vizualiza operațiile anterior configurate, este nevoie să se 
aleagă controlerul pentru care se va genera programul. Este cunoscut faptul 
că pentru controlere diferite (chiar și de la aceeași firmă), programul poate 
să fie diferit, chiar dacă rezultatul în urma executării acestuia este același. 
 
Selectați controlerul astfel: 

- alegeți din bara de meniu opțiunea Machine; 
- în fereastra care se deschide selectați Sinumerik 840D; 
- apăsați butonul Select. 

 
În acest moment programul se va genera pentru controlerul Sinumerik 840D 
al firmei Siemens. 

 

 

Cum se simulează operațiile de prelucrare? 

 

Pentru simularea grafică a operațiilor de prelucrare este necesar, în primul 
rând, să fie selectat tab-ul Toolpath, aflat în partea stângă jos, a ferestrei 
principale. 
 
Vor deveni disponibile, în partea superioară a ferestrei principale, o serie de 
butoane folosite pentru: 

- modul de vizualizare a piesei; 
- selectarea operației care se dorește a fi simulată; 
- selectarea planului în care este vizualizată piesa (2D sau 3D); 
- controlul simulării. 

 
În plus, pe durata simulării, o serie de informații referitoare la poziția sculei, 
operația curentă, scula folosită, etc., pot fi vizualizate în fereastra din dreapta  
ferestrei principale (vezi figura 11.24) 

 

 

Dacă este necesară modificarea parametrilor unei anumite operații, aceasta 
se poate face selectând tab-ul Machining (din partea stângă jos a ferestrei 
principale) și apoi alegând din fereastra Operation (aflată în partea dreaptă 
a ferestrei de simulare) operația care se dorește a fi modificată sau ștearsă. 
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Figura 11.24 Instantaneu din timpul simulării 

 

 

Cum se generează și vizualizează codul programului? 

 

Pentru a putea vizualiza programul, se accesează opțiunea Ncprogram  din 
bara meniului principal. 
În fereastra care se deschide se pot face câteva configurări referitoare la 
modul de numerotare a blocurilor programului principal și ale 
subprogramelor (dacă este cazul). 
Se apasă apoi butonul OK, generându-se programul cu setările anterior 
făcute. 
Pentru vizualizarea/editarea programului, se apasă butonul Edit din fereastra 
care s-a deschis. 
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Exemplul anterior prezentat a avut ca scop principal, familiarizarea cu principalele opțiuni ale 
mediului CAPSmill. În continuare se propune o aplicație care să fixeze cunoștințele anterior 
dobândite și să ofere posibilitatea de a utiliza și alte facilități ale mediului CAPSmill. 

 

APLICAȚIE 

 

 
Generarea automată a codului G pentru 
prelucrarea prin frezare pe o mașină cu comandă 
numerică. 

 

 

Se consideră desenul din figura 11.25. 
Se pornește de la un material brut, turnat, de forma conturului exterior 
al piesei din fig 11.25, având un surplus de 2 mm pe contur, față de 
dimensiunile piesei prelucrate, și o înălțime de 17 mm. Punctul zero 
piesă este ales în planul XOY în centrul piesei, iar pe axa Z la baza 
piesei. Se lucrează în sistem metric și se folosesc coordonate absolute. 

 
 

Figura 11.25 Piesa de prelucrat 
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Problema 1 Să se deseneze piesa, conform schiței din figura 11.25. 
Problema 2 Să se configureze operațiile de prelucrare necesare, 
respectând specificațiile de mai jos, apoi să se simuleze și analizeze 
codul generat: 
 
Cerința 1:  Să se realizeze operația de frezare frontală (grosieră + 
finisare). 
Se fac următoarele precizări: 

- Se va folosi aceași freză atât pentru frezare frontală grosieră, 
cât și pentru cea de finisare, având diametrul de 50 mm și 
teșitura la 45 grade, realizată din carbid; 

- Piesa finită va avea grosimea de 15 mm; 
- Se vor prevedea 0,5 mm pentru operația de finisare; 
- Revenirea la finalul acestei operații va fi deasupra piesei, la  

100 mm față de baza piesei; 
- Parcurgerea suprafeței piesei se va face în zig-zag; 
- Se va prevedea o distanță față de conturul piesei, de 10 mm  

atât la intrarea în piesă, cât și la ieșirea din piesă; 
- Grosimea maximă a stratului înlăturat la o trecere va fi de 1 

mm. 
 
Cerința 2: Să se realizeze operația de frezare laterală grosieră. 
Se fac următoarele precizări: 

- Se va folosi o freză având diametrul de 2 mm realizată din oțel 
de mare viteză (HSS); 

- Se vor prevedea 0,5 mm pentru operația de finisare laterală (nu 
va fi necesară și o finisare la baza piesei); 

- Revenirea la finalul acestei operații va fi deasupra piesei, la  
100 mm față de baza piesei; 

- Metoda de prelucrare va presupune mai multe intrări în piesă 
atât pe orizontală, cât și pe verticală; 

- Intrarea și ieșirea din piesă se vor face după o traiectorie 
perpendiculară pe laterala piesei de la/până la o distanță de 2 
mm față de piesă; 

- Adâncimea maximă de tăiere la o trecere va fi de 5 mm. 
 

Cerința 3: Să se realizeze operația de frezare laterală de finisare. 
Se fac următoarele precizări: 

- Se va folosi o freză având diametrul de 2 mm realizată din oțel 
de mare viteză (HSS); 

- Se va considera numai finisarea laterală; 
- Revenirea la finalul acestei operații va fi deasupra piesei, la  

100 mm față de baza piesei; 
- Metoda de prelucrare va presupune mai multe intrări în piesă 

atât pe orizontală, cât și pe verticală; 
- Intrarea și ieșirea din piesă se vor face după un arc de cerc de 
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450 de la/până la o distanță de 2 mm față de piesă; 
- Adâncimea maximă de tăiere la o trecere va fi de 3 mm. 

 
Cerința 4: Să se realizeze operația de frezare a buzunarului delimitat 
de conturul interior prezentat în figura 11.25. 
Se fac următoarele precizări: 

- Se va folosi aceeași freză folosită pentru prelucrarea grosieră a 
conturului exterior; 

- Se va considera numai prelucrarea grosieră și finisarea bazei 
(fundului) buzunarului; 

- Buzunarul va avea o adâncime finală de 5 mm; 
- Stratul lăsat pentru finisare va avea grosimea de  1 mm; 
- Revenirea la finalul acestei operații va fi deasupra piesei, la  

100 mm față de baza piesei; 
- Metoda de prelucrare va presupune o plonjare în piesă; 
- Intrarea și ieșirea din piesă se vor face după un arc de cerc de 

450 de la/până la o distanță de 2 mm față de piesă; 
- Adâncimea maximă de tăiere la o trecere va fi de 3 mm. 

 
Cerința 5: Să se realizeze operația de găurire preliminară a celor 25 de 
găuri dispuse în caroiaj, la baza buzunarului.   
Se fac următoarele precizări: 

- Se va folosi o freză pentru găurire preliminară cu unghiul la 
vârf de 900 și diametrul de 4 mm, realizată din oțel de mare 
viteză; 

- Vârful sculei va intra 2 mm în piesă; 
- Revenirea la finalul acestei operații va fi deasupra piesei, la  

100 mm față de baza piesei. 
 
Cerința 6: Să se realizeze operația de șanfrenare a celor 25 de găuri 
dispuse în caroiaj, la baza buzunarului.   
Se fac următoarele precizări: 

- Se va folosi o freză pentru șanfrenare cu unghiul la vârf de 900 
și diametrul interior de 1,5 mm, iar cel exterior de 6 mm, 
realizată din carbid; 

- Se va prevedea o întârziere de 2 secunde, înainte de retragerea 
sculei; 

- Revenirea la finalul acestei operații va fi deasupra piesei, la  
100 mm față de baza piesei. 

 
Cerința 7: Să se realizeze operația de găurire preliminară a celor 8 
găuri având centrele pe circumferința cercului cu raza de 50 mm.  
Se fac următoarele precizări: 

- Se va folosi o freză pentru găurire preliminară cu unghiul la 
vârf de 900 și diametrul de 10 mm, realizată din oțel de mare 
viteză; 

- Vârful sculei va intra 5 mm în piesă; 
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- Revenirea la finalul acestei operații va fi deasupra piesei, la  
100 mm față de baza piesei. 

 
Cerința 8: Să se realizeze operația de găurire înfundată a celor 8 găuri 
având centrele pe circumferința cercului cu raza de 50 mm.  
Se fac următoarele precizări: 

- Se va folosi o freză pentru găurire cu diametrul de 10 mm, 
realizată din carbid; 

- Se va folosi un ciclu de găurire cu revenire la punct variabil; 
- Adâncimea utilă a găurii va fi de 5 mm; 
- Adâncimea la prima coborâre va fi de 2 mm; 
- Retragerea sculei după fiecare coborâre va fi cu 0,5 mm; 
- Revenirea la finalul acestei operații va fi deasupra piesei, la  

100 mm față de baza piesei. 
 
Cerința 9: Să se realizeze operația de lărgire a celor 8 găuri având 
centrele pe circumferința cercului cu raza de 50 mm.  
Se fac următoarele precizări: 

- Se va folosi o freză pentru lărgire cu diametrul de 20 mm, 
realizată din oțel de mare viteză; 

- Adâncimea găurii lărgite va fi de 3 mm; 
- Se va prevedea o întârziere de 2 secunde, înainte de retragerea 

frezei; 
- Revenirea la finalul acestei operații va fi deasupra piesei, la  

100 mm față de baza piesei. 
 

Dacă s-au respectat toate cerințele, piesa rezultată în urma prelucrării ar trebui să arate 
precum cea din figura 11.26 (pot exista diferențe în ceea ce privește culorile): 

 
Figura 11.26 Rezultatul prelucrării piesei desenate în figura 11.25 
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Nr. Enunț Răspuns 
A F 

1. În general operația de lărgire a unei găuri o 
precede pe cea de realizare a găurii.   

2. Șanfrenarea unei găuri are ca efect creșterea 
diametrului găurii, în partea superioară a acesteia.   

3. Frezarea frontală se realizează de obicei cu freze 
de tip deget.   

4. Frezarea frontală se execută, în general,  la 
suprafața piesei.   

5. Înălțimea unei piese se modifică în urma operației 
de frezare laterală.   

6. Diametrul piesei din figura 11.25 a crescut în urma 
operației de frezare laterală.   

7. 

În cazul unei freze speciale pentru teșire care are 
unghiul la vârf de 90 de grade, adâncimea 
maximă la care ajunge freza este mai mică sau 
egală cu raza frezei. 

  

8. 

O gaură finală cu diametrul de 10 mm și 
adâncimea de 20 mm, realizată preliminar cu un 
burghiu cu diametrul de 8 mm nu poate avea un 
șanfren rezultat din operația de găurire 
preliminară. 

  

9. Desenarea celor 25 de găuri din figura 11.25 se 
putea face și prin altă metodă.   

10. 

Analizând piesa prelucrată se constată că în cazul 
conturului interior, îmbinarea a oricare două 
semicercuri care compun conturul, se face sub un 
arc de cerc cu raza de 1 mm. 

  

 

 

 

 

 

 

 

 

 

Problema Puncte Total 
Exemplul 1 1 x 4 4 

Aplicație Problema 1 1 x 2,4 2,4 
Problema 2 9 x 0,4 3,6 

Test 1 1 
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